The Planted Tank Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
658 Posts
Discussion Starter #1
My XP2 seems to have died, it doesn't pump anymore and makes loud scraping sounds. I've taken it apart and cleaned it, but no improvement.
I want to replace it with an XP3 since I've added an inline heater and co2 reactor, but I don't really need the extra media space and the added height might become an issue. I see at bigalsonline (http://www.bigalsonline.com/BigAlsU...umpharmaceuticalsrenaxppartxp3motorandoring26) that I can get just the motor and save $20 from the cost of the whole new unit.
Will the XP3 motor fit on the XP2 base? Would there be any problem with doing this assuming that it would fit? Thanks!
 

·
Registered
Joined
·
658 Posts
Discussion Starter #3
i have a xp2 top on a xp3 body... it works
Beautiful... thanks! Did you check out the link above? Would that be all I need? Does it include the impeller, the descriptions are so vague. Thanks again

Dan O
 

·
Registered
Joined
·
9,600 Posts
Since there is only one moving part in the motor you might try replacing that. A impeller is much cheaper than an entire motor.

At best you might get an additional 20-30 gph out of the filter with the new motor.
 

·
Registered
Joined
·
2,601 Posts
Don't forget: at Petsmart.com right now You can get a complete xP3 for 74.99 shipped with the XP3XP4 promotional code. I just checked it about 2 minutes ago and its still working.....:thumbsup:

Looks like its plus Tax for MN. It is for me in TN......Been thinking about, so I finally just ordered one: $82.30 shipped for me.

Also, its currently backordered and may take up to 30 days......:icon_roll
 
1 - 8 of 8 Posts
Top