The Planted Tank Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 · (Edited)
Hey everyone, I have a 10 gallon planted tank with around 5-7 guppies, 2 males and the rest females. I recently got some RCS to add to the tank. On the first batch, I had a few die from around 9. Two weeks later, I bought some more, with a total of probably around 20. Now I can only find four after about 2-3 weeks, and maybe found only two actual dead bodies. I do have a nerite snail, and I've noticed they will eat dead fish so not sure if he just got to the shrimp before i could find them. I also checked the surrounding area in case they jumped out, but i have a cover and top water plants so i dont think thats the case.

Water parameters:

Age: Tank is over a year old and well cycled with plenty of plants and algae
Temp: Usually around 75, ranges from 75-77 with colder temp at night (i use an adjustable heater)
Ammonia: 0
Nitrite: 0
Nitrate: ~20
pH: ~7.5, although i dont usually check it.
I don't know my gH or kH, but planning on checking this. I use well water, so I'm assuming its already hard from being in the ground, although i still do treat it with dechlorinater. My tank is heavily planted, so i dose flourish and excel about twice a week, once after water change and once about 3 days after the water change. I normally do water changes every 3 days but recently slowed down to about a week since my nitrates have been on the lower side with the addition of new plants. I also did add a pothos that was planted in soil, so I'm wondering if that had any copper/lead on it. I can't really think of any other issues, but the thought of overfeeding them did cross my mind. I put in an algae wafer, a few days later some pellets after getting the shrimp plus flakes for the fishes. Now I haven't fed the shrimp in about 2 weeks but make sure to put in extra flakes for the shrimp and as ferts for the plants, and havent noticed any new deaths. Just my four cherries left over.

I suspect two reasons, the addition of new plants could have brought some chemicals over, and i think i might have overfed them at first (first time getting RCS, now i understand that there is plenty of food in the tank)

Thank you all for your help!
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top