The Planted Tank Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter · #1 ·
Hi all, hoping to get some feedback on my odd situation and perhaps some help narrowing down what's going on in my tank. I'm losing angels. One by one they are dying and I can't figure out why. This has been an ongoing issue with me since I've started keeping fish about a year and a half ago. They are my absolute favorite fish, so I'm determined to find out what's going on. This morning I woke to find my oldest angel, which was perfectly fine last night, dead. The other angels I lose typically go in the same way, the only difference is that the day before they die, they hide and refuse to eat. In most cases it always seems to happen overnight. I've checked my parameters and they are fine. I can't figure out any causes for possible undetected, drastic parameter fluctuations. I do regular weekly water changes, typically 30-40%. I dose excel, recommended amount, mostly daily. (I wonder if daily is too much though). About 2 months ago I switched my substrate to MGOPM with Eco Complete cap. I lost a few angels before the switch though. My ph is stable at about 7. Out of tap it is 7.6, but the dw gradually lowers it. Phospates are at about 3-4. GH-4, KH-5, amm-0, NO2-0, NO3-5. The tank is planted. I dosed 1/4 tsp of KN03 once weekly over the course of a few weeks because I couldn't get a NO3 reading and I'm trying to avoid any possible algae issues, been through that headache before. I'm running an Eheim 2217 filter. I’m wondering if the issue could be the release of anaerobic gas pockets from the dirt? I've moved things around a little and have definitely stirred things up a few times. Or could it simply be weak stock in my area? Granted these are Petsmart and Fintastic angels, no offense intended. I don't think it is a contagious disease because there is quite a significant time lapse between deaths. I know there are lots of variables here, but hopefully someone can help shed some light on this. Sorry for such a long post but I wanted to include as much info as possible.
 

·
Premium Member
Joined
·
2,574 Posts
Try a different test kit sounds like yours is off... Also i think you might have a viral problem... When i get on my computer i can type a little better
 

·
Premium Member
Joined
·
2,574 Posts
Fish virus are often species specific so it would make sense that the problem could be viral. Additionally they have a long long latency period where nothing happens for about 3 months and out of nowhere the fish dies. There's absolutely no way to cure fish viruses unfortunately and it's almost impossible to diagnose without someone doing some protein assays/microscopy so there's no way to know without extensive and pricey testing.

IMO I'd leave the tank alone and not add any more angels for a few months. Hopefully the viral particles would have degraded and it will be safe to add a new one. I'd also add one from a fish store that has higher quality stock.
 

·
Registered
Joined
·
118 Posts
Discussion Starter · #6 ·
Fish virus are often species specific so it would make sense that the problem could be viral. Additionally they have a long long latency period where nothing happens for about 3 months and out of nowhere the fish dies. There's absolutely no way to cure fish viruses unfortunately and it's almost impossible to diagnose without someone doing some protein assays/microscopy so there's no way to know without extensive and pricey testing.

IMO I'd leave the tank alone and not add any more angels for a few months. Hopefully the viral particles would have degraded and it will be safe to add a new one. I'd also add one from a fish store that has higher quality stock.
Unfortunately that sounds like a plan. It's still strange to me that the onset is so sudden. I have 2 young ones left. I'll see how it goes with them. Thank you.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top