The Planted Tank Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
192 Posts
Discussion Starter · #1 ·
Just noticed these on my Betta tanks filter, any ideas??

Look like air bubbles in the photo but they’re not




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,737 Posts
Looks like some sort of build up, either that or eggs. Hard to tell.
 

·
Registered
Joined
·
192 Posts
Discussion Starter · #4 ·
Looks like pond snail eggs to me.


Sent from my iPad using Tapatalk
It does but it can’t be, only ever had one snail in their which is an assassin snail, I believe they need male and female to lay eggs unlike nerites etc, I just gave it a little brush with a toothbrush and vacuumed what I could out, will keep an eye on it


Sent from my iPhone using Tapatalk
 

·
Super Moderator
Joined
·
16,109 Posts
While Pond Snails and Bladder Snails can reproduce asexually, these definitely not snail eggs. They're laid in gelatinous patches instead of individually.

This is just a growth of some sort. Without better images, it's tough to identify. But could be a fungus of some sort or even a form of Vorticella.
 

·
Registered
Joined
·
192 Posts
Discussion Starter · #6 ·
While Pond Snails and Bladder Snails can reproduce asexually, these definitely not snail eggs. They're laid in gelatinous patches instead of individually.

This is just a growth of some sort. Without better images, it's tough to identify. But could be a fungus of some sort or even a form of Vorticella.
Thought it was some sort of bacterial build, it’s not a problem now though, I just replaced the filter to a Tidal 35 which I’m super impressed with, all of that growth was only on the filter so that’s now gone


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
13 Posts
it looks like vorticella. it seems you got rid of it by increasing the filtration? curious if these are growing in your filter container?
 

·
Registered
Joined
·
192 Posts
Discussion Starter · #8 ·
it looks like vorticella. it seems you got rid of it by increasing the filtration? curious if these are growing in your filter container?
I’m not sure if they were actually in the filter, that filter got replaced, not due to this, I just wanted to try a HOB filter.

I did notice this morning I have a bit growing on the glass but I’m not 100% sure what it is. That tank is now getting stripped down anyway, having too many issues with green algae and now this stuff growing, the Betta is getting moved into my 60L fully planted high tech tank which I’m sure he’ll love, just waiting for the plants to root a bit more before he moves in.

Will use his old tank as a spare incase I ever need to quarantine anything or as an experimental tank in the future


Sent from my iPhone using Tapatalk
 
1 - 9 of 9 Posts
Top