The Planted Tank Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
241 Posts
Discussion Starter · #1 ·
I have attached a pictures of the algae that I have forming in my high-tech tank.

CO2 is on for 9 hours.
Medium level light is on for 8 hours.

I am dosing low grade ferts at the moment.
Any info/tips would be greatly appreciated.

Thanks!
 

Attachments

·
Registered
Joined
·
280 Posts
Looks like BBA. Just cry.

No... lol. But a few things you could try are...
- first off, prune the affected areas. Once they have that kind of growth on them, they are done for.
- For other spot areas, turn off your filters for 15 minutes then, spot treat with excel using a syringe, wait 15 more minutes before turning filters back on
- cut back the amount of light you use
- set the co2 to come on 2-3 hours before the lights

I wouldn't try doing a ton more stuff right away because there are lots of variables. If you change too much at once you won't know what the problem was. But it could also be that you need more nutrients.

Can you post some more info about your water specs, ppm of co2, the specific ferts you are using? These will be a lot more helpful to get a little bit more targeted approach.
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #3 ·
Lovely, thanks for the reply!

My drop checker never really goes above a med-dark green.
I have just set my CO2 to come up 2 hours earlier. (I did have it set to come on 1 hour before the lights.

Ammonia: 0ppm
Nitrite: 0ppm
Nitrate: 0ppm
dH: 3
GH: 8

Current Ferts: Kent Marine - Planning to switch to GLA, but wanted to get this BBA under control first. Unless Algae does not use the ferts for growth.
 

·
Registered
Joined
·
280 Posts
Your nitrates should be around 10ppm. Your drop checker should be light green by the time the lights come on and green yellow by the end of the photo period. Sounds like you need lots more co2 and more ferts. Read up on EI dosing on the Fert stickies
 

·
Registered
Joined
·
241 Posts
Discussion Starter · #5 ·
Thanks, I wanted to try the PPS Pro, I have a precise automated fert system working. Just using poor quality ferts. That said, I have adjusted the CO2, will that kill off the algea combined with Excel or do I need to mechanically remove all the current leaves with BBA?
 

·
Super Moderator
Joined
·
12,113 Posts
Thanks, I wanted to try the PPS Pro, I have a precise automated fert system working. Just using poor quality ferts. That said, I have adjusted the CO2, will that kill off the algea combined with Excel or do I need to mechanically remove all the current leaves with BBA?
I would mechanically remove all the current leaves that have BBA on them.

I have found that even if the algae dies off (i.e. with Excel spot treatment), the underlying tissue has been degraded to the point it is not worth saving.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top