The Planted Tank Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Folks, I need some help!

I replanted my tank a few weeks ago and purchased some new plants. Some Ambulia, Marble Queen sword and repens. They arrived in great condition - lush and green.

After roughly a month of being in my tank the swords are growing, but some leaves are deteriorating, but my largest concern is with the Ambulia. It seems to have lost its green, turning a more brown and is losing considerable amounts foliage. It is sprouting out some new stems from the roots but I'd still like to figure out whats going on with it. I seem to have this issue with a few other plants I've tried - specifically anacharis and sagittaria. Attached are some pictures of what they look like currently.

https://scontent-atl3-1.xx.fbcdn.ne...=dcb90b00c1dc3f3cfb2552face1b3e37&oe=575448F0
https://scontent-atl3-1.xx.fbcdn.ne...=91e014b06689730ec1087c447a9d0f0f&oe=578F8244
https://scontent-atl3-1.xx.fbcdn.ne...=1b41109657ce4268733c03892daa5622&oe=578C04B6

Water details:
100gal tank
Ammonia - 0ppm
NO2- 0ppm
N03 - 20-40ppm
GH - 8 degrees
KH - 3 degrees
pH - 6.9
CO2 - 30ppm via inline diffuser, pH controller
Flourite substrate, adding Flourish every 1.5 weeks.

Filtration - Fluval G6 and Aquatop CF400, purigen reactor.

Light - Marineland Aquatic Plant LED 60"


Any thoughts on whats causing my issues? I appreciate the help!
 

·
Premium Member
Joined
·
606 Posts
What flourish are you using?
It seems like (and looks like) you are not using enough ferts.

Ben
 

·
Registered
Joined
·
21,012 Posts
I don't think you have enough light to grow plants. As far as I can recall Marineland LED lights are not suitable for planted tanks, except for low tanks, and I think yours is around 2 feet high. Do you know what specific model Marineland light you have?
 

·
Registered
Joined
·
541 Posts
Purigen removes organic wastes but I do not think it removes phosohates or nitrates. It may remove some of the organic matter that eventually may break down into other nutrients. Many planted tanks run purigen in their filters with no adverse effects.

You are only dosing micro nutrients and what macro nutrients you are getting from food and waste. You may get enough nitrate and phosphate from food but it is very low in potassium. Try supplementing with API Leafzone. It has the macro nutrients you are lacking. Do not use it on the same day as the Flourish, they bind to each other and are not available to the plants.

Some plants also melt a bit when transplanted but will recover in a few weeks. You are experiencing that with the new leaves that are coming in. The old leaves may all wilt away. That is pretty normal as long as the new leaves come in.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top