The Planted Tank Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Could some help me ID these two plants please? I got them from a fellow when i bought his tanks and he threw in a bunch of plants. Have ID for all but these two. Sorry pics not the best and had a rash of algae for a bit, but under control now with lesser wattage CFLs. The plants originally almost died off but are slowly coming back now. Thanks.

 

·
Registered
Joined
·
1,334 Posts
first one looks like lobelia cardinalis, second one looks like cryptocoryne I cant remember the species but I have it too
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
Thanks for the reply. I agree on the second as cryptocoryne. I had no idea on the first and will do some research. Again, thanks.
 

·
Registered
Joined
·
185 Posts
unless theres a reference or perhaps a better picture for the first one it'd be hard to say, but most likely a anubias. however for the second pic I would suggest it is cryptocoryne pontederiifolia.
 

·
Registered
Joined
·
1,334 Posts
first one still looks like a young lobelia cardinalis that is in bad shape. does it have a rhizome OP??

+1 to c. pontederifolia
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #7 ·
Sorry, missed this reply. The stem of this plant is quite thick, almost twig size actually. I have stuck this in the sand & it looks like new fine roots starting. Prior it was just floating in water and lights in a spare tank with some other plants that were given too me. Hopefully it will recover enough to continue. Tnx for replies.
 
1 - 7 of 7 Posts
Top