The Planted Tank Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
198 Posts
Discussion Starter · #1 ·
I bought a Aquatek mini regulator and at first it was working fine.

It would make the popping sound as i screwed it on signifying that the CO2 was being released into the regulator. Then one day I was changing the CO2 tank out to a full one, when i tightened it air started hissing out the bottom of the regulator where it attaches to the CO2 tank.

I thought it was my O ring for the CO2 so I put a new one on, sure enough same thing happened.

So I ordered a new one and returned mine. It was working great once again until I had to change the CO2 tank. Now it is doing the same thing once again. It's not the tank, I had it tested in a paintball shop to see if it worked on their regulators. It worked on the original aquatek mini, it worked for a little on the new aquatek mini but now it is back to it's hissing out the bottom.

Ideas?
 

·
Registered
Joined
·
25 Posts
I had an issue where after a few minutes it would start to leak & I think for me it was the paintball tank o-ring going bad. Also make sure to unscrew with a wrench on the flats & not by gripping the regulator because the part that screws onto the tank is also screwed into the regulator body.

Bump: I had an issue where after a few minutes it would start to leak & I think for me it was the paintball tank o-ring going bad. Also make sure to unscrew with a wrench on the flats & not by gripping the regulator because the part that screws onto the tank is also screwed into the regulator body.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top