The Planted Tank Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
Hi everyone. I recently bought some Parviflorus Tropica swords for my betta's 3 gallon jungle. They sent some extra plants so I put some in my goldfish 20 gallon. I planted both of them about 1 week ago.

The ones in the betta tank immediately began developing brown spots and now the leaves are turning yellow. The ones in the goldie tank are doing just fine. Can anyone help me figure out what's wrong with the swords in the jungle?

The setups:
3 gallon Betta tank, 78-80 degrees, pH 6.4, salted at .1% to treat a mold on his fins. I use exel flourish daily and some kind of Iron/Magnesium liquid fertilizer once a week. Substrate is gravel. Light is a 15watt strip that came with the tank and gets a lot of bright light from a window.

20 gallon goldie tank, 68 degrees, pH 7.6, no salt, exel flourish daily and Iron/Magnesium once a week.

In both tanks the plants roots are wrapped in the blue/white filter floss and "planted" in a plastic pot. The rhizome is about 1/2 visible above the surface of the pot. This has worked well with the anubius and amazon ferns in my barebottom goldie tank. The light is a 17watt Flora Sun that I recently put in. Lights are on about 6 hours a day, and the tank gets a fair amount of natural light.

Is it the salt?

Any help would be appreciated. The betta loves his jungle, but the jungle does not seem to love the tank.

Thanks so much!!
mj
 
1 - 1 of 1 Posts
Top