The Planted Tank Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1,974 Posts
Discussion Starter · #1 ·
What is the usual acclimation period for the plants? I have them close to 2 weeks. I noticed that many of the stems have side roots growing. I got them as top trimmings (no roots). Unfortunately, many of them have lost leaves. Some leaves seem to have some holes or dead spots. I don't have any melted leaves. Usually, some of the leaves would just break off. I also see many new leaves growing too. Unfortunately, my red eye tetras love to nip at them. I started EI dosing about a week ago. I have been adding nitrates before that. Would my plants improve in any time soon? Thinking about replacing some of them. I really don't want to if these plants tend to "spring to life" after the acclimation period and starting to grow like weeds...
 

·
Registered
Joined
·
2,334 Posts
Good CO2 is critical, but otherwise, they are not that picky, they root for 1-2 weeks, like many foreground plants, sending down roots.........they they will grow well after.
I know for a fact my plants come from you and I must disagree with the co2 being needed, Mine are growing like weeds with no co2 but richly fertile soil and good lighting, I think the lighting is a little more important than the co2 however algae may be a problem for some without the co2, not for me besides dust though. mine didn't melt much when I put it in, however I grow some emersed also and if yours was emersed expect heavy melt and a bounce back fairly shortly after. I love the stuff and it becomes cichlid food as it grows fast for me
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top