The Planted Tank Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
My tank is about 72 gallons thats heavily planted and lightly stocked. Controsoil substrate, CO2 injected, fertz dosed daily. Tank is probably about 10 weeks old. This is the first Algae problem I have ran into so far

Lights are from fluval Planted 3.0, ramps up 3 hours, On 90% power for 4, ramps down for 3.

CO2 i measure with a drop checker. And about 6-8 bbs. I think the canister is running low as its its measuring at about 750 psi... only have a single stage reactor.

Fertz, 6 ml a day of NilocG thrive plus. It was dosed at 2 ml per day about 2-3 weeks ago and I noticed a lot of potassium problems in my Hygros. Problem with the hygro seems to be better Perhaps i am overdosing? Also dose about 8 ml of excel to help prevent algae... doesn’t seem to be doing much. I started this about maybe 3 weeks ago, maybe the excel is the cause?

Brown Plant Terrestrial plant Tints and shades Annual plant

Plant Rectangle Vegetation Grass Water



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
305 Posts
If your light was consistent, then getting consistent levels of co2 is important to attack Staghorn algae at root cause. Spot dosing with h2o2 and dosing excel with twice a week 50% water changes have helped me in getting better of the algae outbreak.

If the algae build up is isolated go for the h2o2 spot dosing.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #3 ·
If your light was consistent, then getting consistent levels of co2 is important to attack Staghorn algae at root cause. Spot dosing with h2o2 and dosing excel with twice a week 50% water changes have helped me in getting better of the algae outbreak.

If the algae build up is isolated go for the h2o2 spot dosing.


Sent from my iPhone using Tapatalk

I will try that. Before going to H2O2, i will try to spot treat with Excel first. I dont have alot of Algae right now so hopefully i can keep it at bay.

I will have to go out and get another canister pf CO2 soon. I am thinking this maybe the cause since its running out


Sent from my iPhone using Tapatalk
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top