The Planted Tank Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
291 Posts
Discussion Starter · #1 ·
Well got the tank and got some plants. Went to set it up yesterday. Put the sand in and water then the plants. Tried to turn on the pump and the impeller spins but there's no suction. I tried forcing water up the thing and as soon as I stop forcing the water it stops going through the filter. Grrrrr so trying to see if I can get a replacement.



Yes I have nasty cloudy water :(


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
291 Posts
Discussion Starter · #3 ·
I did prime the pump then emptied it and rinsed it out again as I thought the impeler might be clogged. Started pouring water in to prime again and plugged in filter still nothing. Got a ziplock bag filled with water put on the end that is in the tank and squeezed so water was forced up the pipe and suction should have been good but nope it died as soon as I quit forcing water.


Sent from my iPhone using Tapatalk
 
1 - 3 of 3 Posts
Top