The Planted Tank Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi All,

I have a gently used Eheim 2217 (+extras) that I want to sell, but it has not been plugged in for a few years, nor do I have an aquarium any longer. Can anyone advise on how best to test if it is still working properly? I will not put it up for sale unless I'm sure it works.

Thanks for any input,
Howard
 

·
Registered
Joined
·
1,901 Posts
First, I would check it to see if the impeller/shaft and all o-rings are in good condition and installed correctly.

You can use a pail of water, placed above the top of the filter, on a chair or table. Connect the hoses to the assembled filter and prime the filter as recommended in the manual. I usually just suck on the output hose to start drawing water into the filter.

After the filter is primed with water, plug in the electrical cord and it should work. You might want to do this test outdoors in case the filter leaks or a hose pops out of the pail.
 

·
Registered
Joined
·
1,747 Posts
Even if it doesn't work, you can probably get some money for an honestly listed one that is damaged. Eheim has a wide following and there are a whole bunch of replacement parts available. Depending on how you had it stored and the condition of the filter before storage, things like o-rings or gaskets might need replacing soon anyway, even if it doesn't leak when you test it.

Unless you stored it in really poor conditions or it was abused before that, I'd be very surprised if it didn't work just fine, with the caveat of seals mentioned above.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top