The Planted Tank Forum banner

S. Repens losing all its leaves suddenly

794 6
I originally posted this on another forum, so I'll paste what I wrote there with the dates.

01/08
"So a couple days ago, all my s repens in my tank dropped like half their leaves. All my other plants look great, and the s repens has been growing and propagating awesomely in the tank for the past 7 or so months. I use Flourish Excel Seachem 3 times a week, everything is planted in Fluval aquasoil, I have Seachem Flourish Tabs in as well. No CO2. Tank is about 77 F, I do weekly 20% water changes. Pic attached from just before this started happening so you can see all the plants looking good. No new livestock recently.

Recent changes that may have effected something:
-We had a local cold snap, and the water in the tank dipped to around 74.5 F
- The tiger lotus has been in about a month
-I recently reduced my light hours from 12 to 9 to combat algae
-The root tabs are a recent addition, been in about two weeks

You can't really see in the picture since it doesn't show the whole tank, but I have a ton of s repens along the front in various states of maturity. All of them are dropping leaves but don't have any browning or yellowing. I'm not sure what the issue is. For reference even the patch where I just put a root tab a couple weeks ago had the same reaction.
I can get more specs if needed, and I'll take a picture of the s repens later as well."

Reply from someone:
"Excel is not a plant food. You need to feed your plants with a proper water column supplement. I use the Seachem line. There are six that I use: Excel, Iron, Potassium, Advance, Trace, and their root tabs.

I prefer this over the all in one supplements as it allows you to dial in the supplements to the plants needs rather than throwing everything at once at them. Also you want to use the organic and inorganic on separate days. As I understand it there is a conflict between the two. You can not do this with an all in one.

Just my two cents worth."

01/13
"I was afraid that might be the case. I know that excel doesn't have good macros, but I was hoping with the root tabs I'd be good to use up the bottle before getting Aquarium Co-Op's Easy Green. Any ideas what nutrient I might be missing that would make it suddenly drop leaves? All my other plants are still doing great and growing quickly.

The s repens ended up losing the rest of their leaves a couple days after I posted this. They look like this now. :("

Attachments

1 - 1 of 1 Posts

· Premium Member
So many tanks...
Joined
·
746 Posts
Agree with all above, I think it's a melt back. happened to some of mine. I just left them though, they started to grow but much slower and smaller. I don't do nearly as much ferts for water coloumn though. Mostly root tabs, and every so often after a water change will add one of 2 types of ferts that I have. Iron and Monopotassium Phosphate. I have trimmed the tips off these same stems and put them in other tanks and they started to grow amazingly. Personal, theory is mine needed higher light. and do better with a little more attention to the water column ferts.

GL
 
1 - 1 of 1 Posts
Top