The Planted Tank Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
286 Posts
Discussion Starter · #1 ·
i've got 5 species of plants in my nano. 3 of them are stem plants. supposed to be FAST growers.. ludwigia repens, water sprite, rotala indica. they have 9hrs of light a day. i dose excel and ferts every other day. i do ~%50water changes 2x a week. these plants (and the rest) WILL NOT GROW! i cant even get roots to develop on the rotala. the water sprite just sits there. nothing is dying, just seemingly dormant. whats the deal?
 

·
Registered
Joined
·
562 Posts
I would think: first look at light, and then let us know how long your tank has been set up for. I know I've had plants that sat there like dummies for a month or so and then suddenly woke up and started growing... ludwigia most notably!
 

·
Are these real?
Joined
·
15,720 Posts
I thought you reported good growth with the Anacharis?

What ferts do you dose? I imagine it's tough to precisely dose a 2.5gal "tank". Do you have macros covered?

Is there any new growth, if so, how does it look compared to the existing growth?

Be patient... 3 weeks isn't a long time, and if the plants still look good they might still be acclimating.
 

·
Registered
Joined
·
286 Posts
Discussion Starter · #5 ·
the anachris melted when i added excel. i removed all of it. i have 20 watts of screw in flourecents. i dose KNO3 and KH2P04
 

·
Registered
Joined
·
1,896 Posts
I have the same problem, the plants seem to be in suspended animation.

I have had luck with only a few plant species in non Co2 tanks. I never really tried Excel, I hear it is helpful.
 
1 - 6 of 6 Posts
Top