The Planted Tank Forum banner

plant trouble

1770 Views 23 Replies 10 Participants Last post by  meppitech
Hi everyone. This is my first post but been reading threads here for about 5 months and finally have found a great lfs. I cannot grow any plants. I mainly have gals that have been reduced to nothing. I have no ammonia no nitrites. My nitrates don't ever get to over 40 ppm in a weeks time(with weekly 40% water change). Ph is 7. I have a 55 gallon with 2 54 watt HO T5's. Been dosing flourish and excel for 2 weeks. I don't know what else to do. Wasn't planning on co2 until I got some plants started. Please help and thank u in advance for any advice
1 - 3 of 3 Posts

· Registered
Joined
·
689 Posts
And wait you have 4 vals in a 55 gallon tank? This could be the definition of irony but I believe it was sharkfood that may have replied to one of my posts referencing plant growth when I joined. He gave good advice too... plant your tank. Stop messing around and plant it good and heavy (with budget allowing of course). You are putting all of these nutrients into your water column trying to get 4 plants to grow and your going to end up with a hot bed for algae because there isn't enough plant biomass in the tank to use what you are dosing.

Stop by the swap and shop and get your hands on a good amount of plants. Fast growing stems and floaters. Once you have enough plants to out compete all forms of algae then start dosing otherwise you're continually adding nutrients and begging for algae.
 

· Registered
Joined
·
689 Posts
College station is right down the road from me but anyway. Vals will melt with excel, some will even melt with half dose depending on the proximity of the release but on the plus side they are fast growing stem plants that suck up nutrients and propagate quickly when given the appropriate environment.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top