The Planted Tank Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a new tank that I’m working on and this is my first canister filter. First couple days everything was fine but after a couple days a plastic smell seems to be in the water. I opened up the filter and really smelled like plastic. Thought maybe the tube case for the heater was touching but it wasn’t. Everything seems normal other than the smell.
Is this something that happens with a new filter and tubes? I have a oase 250 and opened up it’s box and sniffed the hose and there is a smell.
 

·
Registered
Joined
·
3,998 Posts
I have a new tank that I’m working on and this is my first canister filter. First couple days everything was fine but after a couple days a plastic smell seems to be in the water. I opened up the filter and really smelled like plastic. Thought maybe the tube case for the heater was touching but it wasn’t. Everything seems normal other than the smell.
Is this something that happens with a new filter and tubes? I have a oase 250 and opened up it’s box and sniffed the hose and there is a smell.
Some people are more sensitive to new plastics then others. All plastics will off gas when new. I have never noticed this problem but I also know I am less sensitive to smells then some.
 

·
Registered
16g rimless cherry shrimp, 20g cube dwarf cichlid, 40g breeder nano community.
Joined
·
611 Posts
I have Oase 80, Thermosmart 100 & 200, Biomaster 250 & 300 filters and haven't had any smell issue that I remember. The newest one, the 80, has been running for 2 months now without issue. The longest, the 100, has been running for 2 years.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top