The Planted Tank Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
392 Posts
Discussion Starter · #1 ·
Hello, im really new to this and need some help with fertilization. Im currently running an ada 60p with archaea 24" lighting system, eheim 2213 filter and no co2 system. I have in the tank some hair grass, japoinica, java moss,micranthemum, mryothyllam, nana petite, and some trident fern.

I am currently running into some bba all over each blade of hair grass and japoinica and green hair algae all over my java moss. not too sure on the substrate cause the setup was purchased used everything except the plants and filter.

considering majority of the plants that i have are low light i figured that keeping the light on over 9 hours was causing the alage growth so i cut that down to 4 hrs a day. so my next question is if my plants need ferts?

the only thing is that i plan or putting in CRS and CBS into the tank and don't want to use anything that will harm the shrimps.

does anyone have any suggestions on what is should do and what brands i should use?

oh and the circulation seems to be ok my japoinicas and hair grass are all swaying. i used that 5 in 1 strip quick dip test kit so im not sure if this method is accurate for what i am doing.

please help mewbie getting frustrated :angryfire any suggestions on my setup would be greatly appriciated also
 

·
Are these real?
Joined
·
15,712 Posts
Yes... most likely your plants need nutrients (including CO2).

Isn't 4 hours light period a bit short? I dunno... I have my lights on 12 hours. :wink:

Don't be too concerned about your shrimp. They will do much better in tanks where healthy plants grow. Even if that includes adding CO2, macros and micros. All in proper dosage, more isn't necessarily better.
 
1 - 2 of 2 Posts
Top