The Planted Tank Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Hi, I'm new to the idea of having a planted tank. I love this site. I have a 75 gal tank. It's 48" wide. I have an AC110 filter. I'll be using a double fluorescent light, one pink 54W and one white 54W 6500K. I hope that will work out. I want a low tech tank with no C02 and no algae. Very funny right?

I just planted it with some swords of different sizes, water wisteria, java fern, some crypts, some cardinalis, pygmy chain sword and some dwarf hair grass.

I'm excited to see my tank clear up so I can see what it looks like. I used all fluorite for the substrate and didn't rinse it first.

When I put the filter intake pieces together I noticed one is cracked about an inch long. Can I run a fine bead of super glue over that to prevent it from further cracking? I plan on having several angels and a school of cory's.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
Very Cloudy Water Today

Thanks for the info. on glue. Your 110 gal. is beautiful. You must have a lot of hours into it, but worth it in the end. I particularly love the color variations in your plant choices. Love your koi angels, I want a couple of them just like yours, they're perfectly colored.

I finished filling my tank around midnight. I put a dose of clarifier in it because it was so murky. I told my husband it looks like a swamp, all I need now is an alligator! This morning it doesn't look any better. Should I drain and refill it? The package of fluorite said it's not necessary to rinse but if I'd of only known.

I haven't fertilized yet. Are my plants OK for a while? Does fertilizer cause algae? I will post a picture in a few minutes.
 
1 - 3 of 3 Posts
Top