The Planted Tank Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Im new to thisforum and hoping to get some answers. I really need help getting rid of some white fuzz in my tank. It's on my plants and now on my substrate. I researched and even posted on some forums but no answers, please help, it looks really ugly:(I'll post pics when I can.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
I did a big water change yesterday, and how will the carbon get it if its hard to get off?:( i added three ramshorn snails, taking the risk that they breed rapid but moved my wisteria to the 10 gallon since that stuff was all over and they cleaned it up really good so i added three to see if they could clear it up. Ive had this for maybe.. at least a month and its spreading everywhere.
 

·
Registered
Joined
·
6,186 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
what's tlc? I don't think it's unhappy, the plant roots are really good and that's how the plant grows, it gets red under good light. it's on my vals, wisteria and substrate now and spreading everywhere. it's a 36g bowfront, lighting is 2×24 watt t5ho Nova extreme.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #11 ·
oh! I try my best for all my tanks and spend alot to make em the tanks I always want since I was young. and I think it's a Pygmy chain sword. also my tank is moderately planted. it's on my vals too and they're healthy.
 

·
Registered
Joined
·
45 Posts
The plant looks like dwarf sag. I've seen that white fungus stuff before if you have a big piece of uneaten food left on the bottom of the tank for too long. But i've never seen it all over before
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #14 ·
it's hard to see the red on it cause of the white stuff, also my substrate is floramax, dose excel, dose flourish comprehensive but stopped to see if that was the problem. I run two filters both for a thirty gallon, an aquaclear and aqueon. also run two DIY co2, drop checker is at lime green to yellow. as for my water parameters, I will have to do that in a while, gotta pick up brother from school. will list plants also in a bit.
 

·
Premium Member
Joined
·
3,594 Posts
it's hard to see the red on it cause of the white stuff, also my substrate is floramax, dose excel, dose flourish comprehensive but stopped to see if that was the problem. I run two filters both for a thirty gallon, an aquaclear and aqueon. also run two DIY co2, drop checker is at lime green to yellow. as for my water parameters, I will have to do that in a while, gotta pick up brother from school. will list plants also in a bit.
Light period?
 

·
Registered
Joined
·
2,056 Posts
I don't think it's a mini cycle, and yes but it's not yeast gunk. I was told it's water mold.
If you have ANY amount of ammonia in the water, it IS a mini cycle

OR

You are over feeding or under filtrating.


Also, how do you know its not 'yeast gunk'? It looks exactly like 'yeast gunk' to me. If you are not using a bubble counter style bottle as a filter then it very well could be!
 
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top