The Planted Tank Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I had a out break of algae and I dosed it two days with Excel... It is all red now.. I going to do a 50% water change this evening..

Should I keep using Excel for a few more days??

Thanks
 

·
Premium Member
Joined
·
2,574 Posts
Keep going. It's on its way out. I'd do a WC then resume the regimen. Stopping now will only give you nascent problems even harder to cure.
 

·
Registered
Joined
·
1,945 Posts
Red Algae

Hello cap...

Good idea to change out half the tank water. I'm not sold on the use of "algae destroyers". Chemicals will kill the algae very quickly, but the decaying and dead stuff just creates more nutrients for the next algae bloom.
I'd like to put in a vote for dealing with algae the "old fashioned way" next time, by beginning an aggressive water change routine. Every week, change half the tank water and start planting fast growing plants that consume a lot of nutrients, like Water sprite (floated), varieties of Hygrophila, Anacharis, Pennywort and Hornwort.

There are natural ways to deal with algae. Those are by far the best.

Just one old "water keeper's" opinion.

B
 

·
Plant Clown
Joined
·
4,735 Posts
Exactly how much Excel are you using? Spot-dosing directly onto algae I can definitely believe would cause red algae within 48 hours. Doing a standard tank overdose, however, shouldn't have that effect so soon, should it?

If you're dosing more than three times the standard (daily, not startup) dose, you're going to destroy your plants. The ones you want to keep, anyway.

Just wanted to make sure you're not overdoing it.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #8 ·
I used a double dose per the the instructions on the side and then a single dose. I did a water change last night and did a double dose. I plan to also do single doses until it is completely gone.

Also, I have been working on this for over a week with decreased light, 4 on, 3 off, and 4 on.

I also increased my c02 just a little... Drop checker is lime green.. KH is 8 and I have my controller set for a ph of 6.9. And it tested fine before the water change this evening.

I also started EI dosing 6 days a week..

I really think I know how I caused this from the start and want to correct it and not use excel any longer. There was a three week delay getting my c02 system and I did not EI dose during that time. Based on some advice I just used Flourish twice.

All the plants look good now and growing like crazy... I'm going to need to trim a few this week some time..

All the fish are doing fine..

I have really learned a lesson in the balance of the aquarium as it relates to light, ferts and C02!

Thanks for all your input... I'll try to get pictures tomorrow..
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #10 ·
I understand what a couple of are saying, but that's how it happened..I have no need to bs anyone, heck I'm so new to this that I still spend hours a day researching..

My Excel calls for 5ml for 10gal for inital dose.. I have a 72 bowfront but I count it as 60g so I used 5x6=30ml as a dose. I doulbed it the first day and did not the second day. I used a 30ml turkey injector I found at the supermarket and shot it down by the algae with the canister turned off and let it sit for 30 min.

What I'm still after is when can I go back to not dosing excel and normal lights and c02. Do I have to wait until it is completly out of the tank... I'm assuming that it next turn white and then disapear.

Someone asked for pictures so here are some before and after pictures:

Before



After



 

·
Registered
Joined
·
755 Posts
That is very dramatic looking. It's a pity the only way to get that contrast is to develop algae and then kill it off.
I could be wrong, but I don't see why you had to stop dosing CO2 during this time, although I'm not sure what the rotting algae will do to your O2 levels.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #13 ·
I didn't stop dosing c02, I just increased it. I have a kh of 8 and had my controller set at 7.1. I changed it to 6.9 to increase the c02 based on a little research. I didn't want to any higher for the sake of my fish..

I would like it change it back to 7.1..
 

·
Plant Clown
Joined
·
4,735 Posts
My Excel calls for 5ml for 10gal for inital dose.. I have a 72 bowfront but I count it as 60g so I used 5x6=30ml as a dose. I doulbed it the first day and did not the second day. I used a 30ml turkey injector I found at the supermarket and shot it down by the algae with the canister turned off and let it sit for 30 min.
That's what I mean about doubling or tripling the daily dose but *not* the initial dose. Discontinuing that dosage, regardless of the reasoning, was a good idea. The initial dose is 5x the daily dose. Doubling it would be 10x the daily dose, rather than simply tripling it.

Overdosing with Excel, with your tank, at triple strength, would be at a recommended 21mL for 70g, for 10-14 days.

Regardless, I'm glad your algae got hit hard, and I hope your plants don't show any negative reactions in the next few days. Good luck!
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #16 ·
Now I really feel like a idiot... My plants are looking fine so far.. I guess that's why I'm posting here.. I will get this figured out and balanced.

I'm going to go back to 8 hours of straight light today. I'm continuing my EI dosing and water changes..

I'll continue the Excel at double the rate(14ml) until this gone.

I will let you know how it it works out.

Thanks for you input and help..
 

·
Registered
Joined
·
689 Posts
No, do not continue dosing. Red is good and red is dead. However now comes the hard part of dealing with the water/light/fert parameters in order to destroy the algae building blocks... this is the hard part. I would hold on to my dosing material because algae fights are usually long drawn out wars with multiple battles. I wish you luck sir.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top