The Planted Tank Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
703 Posts
Discussion Starter · #1 · (Edited)
After following Momotaro's ma957 instructions, http://www.plantedtank.net/forums/planted-tank-faq/18272-milwaukee-ma-957-co2-regulator-instuctions.htmlI noticed I could not reach 10lbs of pressure on the low pressure gauge. Once the pressure reaches 8 lbs or more, co2 starts releasing out of a valve to the left of the adjustment knob and below the high pressure gauge.

I currently have the low pressure set at 6 lbs and split between two tanks at roughly 2 or 3 bps. Which looks like it will be all right, but this is day 1 with me owning a running pressurized setup, so I am not sure whats right and wrong. Any idea why it cant reach 10 lbs without leaking or releasing co2? Is having it at 10lbs necessary? or will 6 be okay?
 

·
Registered
Joined
·
220 Posts
Sounds like a bad regulator leaking from the diaphram. Can you show us a picture of where the CO2 is coming out. Is it coming out of the holes near the adjustment knob?
 

·
Registered
Joined
·
703 Posts
Discussion Starter · #4 ·
It is only leaking in this one spot, and only when i reach 8lbs+ like i said before. sorry for the blurry pic, hopefully you can get an idea of what your looking at though. Thanks!
Its the blurry brass little circle in the center of the photo.
 

·
Registered
Joined
·
703 Posts
Discussion Starter · #6 ·
Siiigh. Its brand new from http://www.co2-canisters.com/index.html. These guys are not the best with customer support either. They never answer the phone, and they take a millenium to email you back. They sent out my regulator, and forgot to send me my co2 tank. It took them all most 2 weeks later to get me my tank. (which i got today)
That's what i get for not going through GLA, and for getting a milwaukee...Doh!
 

·
Registered
Joined
·
21,012 Posts
Most pressure gages on regulators have two scales, one inside the circle, one outside the circle. Are you reading the right one? That leak seems to be from the pressure relief valve, suggesting that you have a lot more than 10 psi - perhaps 150 psi?
 

·
Registered
Joined
·
703 Posts
Discussion Starter · #9 ·
On the gauge on the right I was reading the outside cirlce which was in black numbers(psi i thought), and the inner circle had red ones i believe. On the left gauge, it read a little over 50 psi.

Sorry, just realized my link was bad. fixing
 

·
Registered
Joined
·
703 Posts
Discussion Starter · #10 ·
I did set it up when it was cold, and I did not have much time to sit and stare at it for a while(got called into work tonight) to see if the pressure changed in the left gauge (high pressure correct?)
I could very well have been reading the gauges wrong. I do have those moments of dislexia here and there.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top