The Planted Tank Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
327 Posts
Discussion Starter · #1 ·
Any idea what would kill this? I had a CO2 supply issue where I didnt have it for a week+, I added it back about a week ago. During this time I didnt dose fertz much, when I got it back i forgot a few EI doses and started back on it and BAM, almost over night (at most two days). Went from green to mean..

S. repens, micro swords, A. Reineicki and baby tears are coming back and didnt die off like this. I may have dosed a lil more micros then I should right before this, but not too much.

Fluval Spec V
FLoraMax/Laterite/Flourite sand substrate
pressurized CO2
EI dosing
Finnex planet + (8hrs a day)

 

·
Registered
Joined
·
1,629 Posts
I recently added Java Moss to some driftwood and had the same problems, browned in 2 days. It is coming back a bit with some new green growth though. I'm eager to see what others think. My tank is injected co2 and dosed EI, but I didn't miss any doses nor was co2 off.
 

·
Honeycomb Master
Joined
·
6,769 Posts
This usually happens when moss has been exposed to heat for too long (e.g. during shipping). It may look fine or only slightly damaged when it arrives, but it usually has a hard time recovering. Where did you purchase it from?
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #5 ·
Again it might have been a couple days. But one day it seemed fine, nexrt time i look its toast. Ive had this moss in this tank for over a month+. Grown about 2x the size, then boom. Especially since I just got everything back in order, seems odd it would die now. Heater is working fine and keeps it p constant
 

·
Registered
Joined
·
327 Posts
Discussion Starter · #7 ·
It could be, Im pretty sure I spooged just a lil to much micros in, but at most 2x the amount (1 squirt vs half a squirt). It is in a 5gal tho so less water to buffer my mistakes. It is not the first time I have over dosed those tho, kinda hard to get just a half a squirt
 
1 - 7 of 7 Posts
Top