The Planted Tank Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hey All,

My inline diffuser seems to be having some issues. I recently switched my CO2 canister and I don't see any bubbles coming from the output now. I'm wondering if it has actually been slowing down for a while but I'm not sure. I can't find any leaks and there is CO2 coming out of the tube from the regulator (I checked with a glass of water).

Any ideas what is going on?

I should also note that I have another tank hooked up to the same regulator with an in-tank diffuser. That is working fine.
 

·
Vendor
Joined
·
47 Posts
Hey All,

My inline diffuser seems to be having some issues. I recently switched my CO2 canister and I don't see any bubbles coming from the output now. I'm wondering if it has actually been slowing down for a while but I'm not sure. I can't find any leaks and there is CO2 coming out of the tube from the regulator (I checked with a glass of water).

Any ideas about what is going on?

I should also note that I have another tank hooked up to the same regulator with an in-tank diffuser. That is working fine.
It is hard to identify the cause of this issues but can you let us know when you last cleaned the Inline diffusers ceramic element? Another thing to consider is that when you switched everything back on, you may not have set the working PSI to the same level as previously which, without a high enough psi, the inline regulators cannot work correctly.

Finally, does your canister filter require cleaning?
 

·
Registered
Joined
·
646 Posts
Here is a quick tutorial about cleaning one of our inline diffusers.
Nice video except that it shows how to assemble a new diffusor, not how to clean one.

PS. Hopefully the cleaning video has dubbed in commentary and forgoes the pounding music.

By the way I use a CO2Art diffusor and love it. Very efficient and the bubble size is very small. I have two and just rotate them out for cleaning.
 
1 - 5 of 5 Posts
Top