The Planted Tank Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I swapped from an internal to an external filter, but was surprised how noisy it is.

Using my phone to measure it is normally 40 decibel. The noise/vibration seems to come from inside the plastic lid and is kind of a humming noise.

If i lightly touch the lid, to stop the vibration, it is 30 decibel. (as measured by my phone using decibel x app). For now i have placed a small rock on the top to make it quieter.

I looked at impeller, it seems clean and fine. (I never opened it before installing it, so should be like from the factory)

Am i expecting too much, or is something not right?

Marty
 

·
Registered
Joined
·
12,307 Posts
Yea that's not normal. When new they are usually quite quiet
 

·
Registered
Joined
·
263 Posts
I swapped from an internal to an external filter, but was surprised how noisy it is.

Using my phone to measure it is normally 40 decibel. The noise/vibration seems to come from inside the plastic lid and is kind of a humming noise.

If i lightly touch the lid, to stop the vibration, it is 30 decibel. (as measured by my phone using decibel x app). For now i have placed a small rock on the top to make it quieter.

I looked at impeller, it seems clean and fine. (I never opened it before installing it, so should be like from the factory)

Am i expecting too much, or is something not right?

Marty

They are pretty noisy when there’s air trapped in them. If you gently rock it a bit you should get the air out pretty easily. You’ll know because you’ll see it shooting out your return


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
284 Posts
I've run eheim filters for years and they should be almost silent. The reason I keep buying them actually.

I had issue with air getting in my filter recently and couldn't figure out how I was getting air in the filter. The filter would burp every 45-60 minutes. I did maintenance on the filter and made sure to reseat the head carefully and also checked the O-rings on the quick connects. Not sure if it was the head seal or the quick connects, but it stopped pulling air and burping.

Not sure if this is the case for you, but it couldn't hurt to have a look. Hopefully you can get it figured out they are great filers!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
thanks for confirming. I will continue to investigate what is wrong. i already wrote to eheim company company asking for support.

Yes, its very noisy with air when priming, but this is different.
 
1 - 6 of 6 Posts
Top