The Planted Tank Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter #1
Hi ,everyone


Let me start ... I had a 30 gal planted tank and was very successful with it for about 4 years now. I upgraded to a 90 gal , I have as substrate , Flourite and below that I have Flora base then fine gravel as the bottom layer . I have 4- 48" long lights for the tank ,flora sun and tropic sun. Lighting I run for about 10 hours a day . For filters I have two Eheim's .
I'm having problems with water clarity , Its cloudy and now I'm have a problem with green algae. This has been going on for about 4 weeks . I have done 25% water changes and nothing.

any ideas?
 

·
Registered
Joined
·
69 Posts
Only 4 weeks? Could be the typical bloom. Has it cycled? Planted, if so how much? Are there fish in there? You need to post more info.
 

·
Registered
Joined
·
21 Posts
probly just the cycle throw some starters in there and let it go for about a month or so
 

·
Registered
Joined
·
3,199 Posts
And the diatom bloom is next at about one month usually. All normal, but a pain nonetheless.
Agreed you want to pack it to the brim with fast stems to speed up balancing.

If its green water algae, easy fix is to buy/borrow a UV clarifier like the turbotwist. Other green algae problems, well, depends which one. I take you are injecting CO2. If you can up it, that will help.
 

·
Registered
Joined
·
167 Posts
Discussion Starter #6
re-help

I have about 15 fish in the tank I have used Bclear biological water clarifier
this works well for about a day or two then the tank goes back to being cloudy?
 

·
Registered
Joined
·
21 Posts
I have about 15 fish in the tank I have used Bclear biological water clarifier
this works well for about a day or two then the tank goes back to being cloudy?
The more additives you add to your tank the longer its going to take to cycle Let it do its thing for a month or two expecially with that size of a tank :proud:
 
1 - 8 of 8 Posts
Top