The Planted Tank Forum banner

1 - 5 of 5 Posts

·
Banned
Joined
·
22 Posts
Discussion Starter · #1 ·
I have a 5 gallon stricky plant grow out tank,

I have mosses, and frogbit along with duckweed. Small sponge filter running, along with a DIY co2 system. 2 WPG

I want my plants to grow fast, I use the PPS Pro method for fert, and I also dose excel once daily, it has been about 2-3 weeks not and nothing has grown at all or at leats noticeable. some of the Frogbit has lost its green color and is turning whiteish yellow

my water I just tested is as follows
Ammonia .25PPM
Nitrite 0 PPM
Nitrate 160 PPM

I use the water I sphion out of my other tanks and add it to this one.

What am I doing wrong if anything?
 

·
Super Moderator
Joined
·
11,986 Posts
What kind of lighting do you have? 2 WPG is not very meaningful, since it can really only be applied to T12 bulbs (which I assume you are not using).

Also, your nitrates seem to be ridiculously high. I would do some water changes to bring it down to ~20 ppm.

Since you are dosing using PPS-Pro, I assume you also have phosphates available.

If you are injecting CO2 via DIY method, there is no need for Flourish Excel.
 

·
Registered
Joined
·
11,721 Posts
Ditto: What sort of light? I am getting crazy growth from frogbit with very good light, but low levels of fertilizer. CO2 is unimportant to floating plants; they get their CO2 from the air.
 

·
Banned
Joined
·
22 Posts
Discussion Starter · #4 ·
The light I am using is a Zoo Med ultra sun,

My light hood for this 5 gallon has one of the screw in light blubs so I cant really do much with it.

Is there another way to light my tank?

also do nitrates pose a problem for the plants?
 
1 - 5 of 5 Posts
Top