The Planted Tank Forum banner

Help with Green Spot Algae.

787 Views 2 Replies 2 Participants Last post by  AwwShucks
Hey guys!

So I have been getting a lot of GSA in my 15 gallon tank, and was wondering if any of you know what I can do about it.

For note, I do have a nerite snail, however I think it is too much for him to eat on his own haha. Poor Pablo.

Anyways, I've heard you need to add phosphate to get rid of it, and I checked, I have 0 phosphates. Is this true, and if so, what product do y'all recommend I add?

IMGUR ALBUM: https://imgur.com/a/2zUXuNS

Tank Parameters

Ammonia: 0
pH: 7.0
GH: 5-6 aka 89.5 to 107.4 ppm
KH: 3 aka 53.7 ppm
Nitrites: 0
Nitrates: 0
Phosphates: 0

I have been dosing NilocG's Thrive S, but I'm not sure it's cutting it. I do 3 pumps, 3x a week (MWF). I'm bummed that I've yet to see any nitrites/trates while dosing this fertilizer. I think I did a water test once where it was 40 nitrates but that's it.

I have 5 ADFs (frogs), 3 Amano shrimp (hence ThriveS), 3 otos, and various pest snails + Pablo the nerite.

(See Pics, above)
My anubias in particular has some edges that broke off and have never come back, and my s repens is beginning to get some holes in it, as well as the algae. Any recommendations on what I should change? Is this fertilizer just not right for me?

Any advice helps :)
1 - 1 of 1 Posts

· Registered
Joined
·
306 Posts
Before tinkering with phosphate levels and additives I suggest if you could just scrape out the GSA, cut out the leaves with gsa followed by large water changes. Try this for 2-3 water changes and see if it keeps coming back?

I had GSA in my 30 cm cube and this method worked for me. Now I have some Green dust algae in my tank but no relapse of the spotted variety.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top