The Planted Tank Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
521 Posts
Discussion Starter · #1 ·
Hi All,
I just won a ROAK for some Blyxa Japonica. It shipped quickly, and I acclimated it well but am not sure of the the senders parameters. I am wondering if my parameters are too different from theirs and this is causing a problem. I have heard of Crypt melt, is this something like that? The plants looked to have a pretty good root system, will it bounce back?
Here are some pics please help!


 

·
Registered
Joined
·
521 Posts
Discussion Starter · #4 ·
Thanks for the input. I can't wait for it to bounce back!
 

·
Registered
Joined
·
3,890 Posts
yah, I have had no luck with this plant either.

I almost wonder....if you get new plants, would it be better to cut off all of the leafs, plant it, and let new leafs form from the nearly bare stem? I bet it wouldn't float as much that way....
 

·
Registered
Joined
·
711 Posts
yah, I have had no luck with this plant either.

I almost wonder....if you get new plants, would it be better to cut off all of the leafs, plant it, and let new leafs form from the nearly bare stem? I bet it wouldn't float as much that way....
i always trim off a few sets of leaves, not the whole stem. i leave about a quarter of the leaves i cut. that makes it easier to plant and less apt to uproot.

as to the op, looks like yours took a beating during shipping. no light tends to make the leaves translucent. it should bounce back, give it time. pretty hardy plant ime and grows like a weed; i toss a handful every month or so in my compost pile.
 

·
Registered
Joined
·
521 Posts
Discussion Starter · #8 ·
Thanks Milesm and Hybrid.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top