The Planted Tank Forum banner

HELP Dwarf puffer.. extreme slime coat? fungus? velvet?

3643 Views 5 Replies 5 Participants Last post by  wildroseofky



When feeding the dwarf puffer today I noticed his markings seemed off. Upon closer inspection I noticed physical bumps all over his body! He still have an appetite and ate veraciously... he's in a 12g long with cherry shrimp and otos, tanks has been set up with fish and planted (running) for over a year and a half. Water parameters have not fluxed (pH 7.5, gh 40, kh 80, tds 210-ish temp 76F), 0ppm across the board (ammonia/nitrite/nitrate). I do not see flashing or other sighs of illness in the puffer, otos and cherry shrimp appear un-effected.
ADDED: I will note I dose liquid seachem ferts in his tank and he tends to hover right by where I inject the liquid in (hoping I'm going to feed him instead) ferts include: flourish(0.2ml), iron(0.4ml), phossphourus(0.6ml), pottasium(0.2ml), and excel (3ml)-this is a 12g tank. Is it possible he's reacting to the ferts dosed pretty much in his face withe extra slime coat protection?
Any clue what is up with him? Slime coat on overdrive? Fungal infection? Velvet (I hope not)?

Sorry I cannot get an better photos, he is horrified of the camera =.=
1 - 1 of 1 Posts

· Registered
Joined
·
327 Posts
Here is a link to a forum dedicated to Puffers. Lots of great info and really helpful members. You could add charcoal to the filter if you think the fertilizer might be the problem. I have squirted fertilizer right on fish, not trying to they just swam into the stream, and never had one show a problem. Check with the people over at the puffer sight to see if you can use salt just in case it is an infection or a parasite.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top