The Planted Tank Forum banner

21 - 24 of 24 Posts

·
Registered
Joined
·
10 Posts
I have had the Biomaster Thermo 250 for about 2 months and haven't had any issues. Using matrix and purigen along with aftermarket inflow (w/skimmer)/outflow pipes but otherwise no special treatment. It coughs up some air when you first start it up but that's it.
 

·
Registered
Joined
·
1,706 Posts
I am in the same boat as you, OP; well, sort of. I was going to upgrade my filter, from EHEIM 2215 to the Filtosmart 200, but even reading those models, some folks have stated there were 'random noise' at exact intervals (perhaps coincidence).
 

·
Registered
Joined
·
3 Posts
For what it's worth, make sure your intake side (inlet strainer, inlet pipe, inlet tubing) isn't too restricted. Both my Fluval 307 and Filstar XP3 began purging air at regular intervals when I neglected to clean the sponge re-filter I had on the intake tubing. It seems the restriction caused the pump to create sufficient negative pressure for the filter to pull in air from any other tiny gaps available. The system never leaked water.

So check to see if your intake tubing has any kind of restriction. Make sure there isn't excess debris or mulm that's restricting the intake tubing or strainer. What kind of intake tubing are you using?
 

·
Registered
Joined
·
331 Posts
Tried petroleum jelly this morning. Filter is the same.
I pulled my Filtosmart Thermo 100 apart on Friday night as it was sucking air again. I rinsed the sponges, cleaned the impeller and wiped the edges where the top and canister meet on both parts. Put it back together and it will work fine for a month or two and then start sucking air again. I now have 4 different sizes of Oase canister filter on 4 different tanks and this one is the only one that has chronic issues with air. Jelly works, but I don't really think the issue is the gaskets (obviously the petroleum jelly is to keep the gaskets from drying out). I don't think this particular canister's top locking mechanism holds it all tight enough. It's not an issue on the 200 that has the same design.
 
21 - 24 of 24 Posts
Top