The Planted Tank Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
288 Posts
Discussion Starter · #1 ·
9 days ago planted them

Fert: tropica premium
Seachem equilibrium
Exel 50% of recomended dose
Co2: 7hrs
Light: chihiros a-plus 6hrs

Rest all plants doing fine.


Sent from my POCO F1 using Tapatalk
 

·
Registered
Joined
·
1,110 Posts
That leaf right above the center of the picture, looks as if it's turning translucent. It might be on the verge of melting.
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #4 ·
That leaf right above the center of the picture, looks as if it's turning translucent. It might be on the verge of melting.
Yes, same with my pearl weeds. What can be the issue?

Sent from my POCO F1 using Tapatalk
 

·
Registered
Joined
·
38 Posts
I know excel doesn't play nice with certain plants, but don't think those are on the list that it hurts. Did you make any changes to water parameters lately? Plant melting is usually linked to plants adapting to new parameters. Oh wait, since you added them 9 days ago they're still adjusting. Give them time to acclimate to your tank parameters, remove dying growth, and hopefully you will see new growth come in.
 

·
Registered
Joined
·
288 Posts
Discussion Starter · #8 ·
I know excel doesn't play nice with certain plants, but don't think those are on the list that it hurts. Did you make any changes to water parameters lately? Plant melting is usually linked to plants adapting to new parameters. Oh wait, since you added them 9 days ago they're still adjusting. Give them time to acclimate to your tank parameters, remove dying growth, and hopefully you will see new growth come in.
Been a month now. Had zero po4, so just got k2hpo4 today. Dosed as per EI daily on rotala calculator.

Sent from my POCO F1 using Tapatalk
 
1 - 8 of 8 Posts
Top