The Planted Tank Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
So as the title says I am struggling to dial in PPS PRO ferts in my tank. I started infusing pressurized Co2 about 4 months ago and decided to use this method of fertilization. I thought I finally found a sweet spot in the balance but a snail crawled out of my tank which prompted me to check my parameters and it was 0-0-40/80 (can’t tell the difference)

To note this was a week after the canister filter was cleaned (in tank water) and 2 days after a 50 percent water change. So I went to work researching and because my tap has about 15-20 nitrates I decided to remix my macros and take out the kno3 and replace it with a 50 percent increased dose of k2so4 to replace the K. I rechecked my and nitrates are coming down now.

So my current problem is my slower growing plants are developing holes in the leaves and I suspect a K deficiency. Java ferns, Buce, and a sword plant. How in the world do I add more potassium in this situation??? The stems look fine.

Tank is 44 gallons which I would consider heavily planted, PPS PRO 9ml macro and 4.5 micro daily, Co2 with drop checker lime green at end of day, I have a power head, surface skimmer and eheim 2217 canister. Not heavily stocked.

Any help appreciated
 

·
Registered
Joined
·
707 Posts
@Edward thought I would try PPS for a change. First time I ever used CSM +B is it supposed to be yellowish green?
I wonder if the Copper oxidized a little, it all dissolved in solution so its probably okay. I had a sealed package from NilocG that I never used for about 2 years I wonder if it went off.

Also is 10ml/250ml water enough Excel to inhibit mould?
 

·
Registered
Joined
·
1,505 Posts
@Edward thought I would try PPS for a change. First time I ever used CSM +B is it supposed to be yellowish green?
I wonder if the Copper oxidized a little, it all dissolved in solution so its probably okay. I had a sealed package from NilocG that I never used for about 2 years I wonder if it went off.

Also is 10ml/250ml water enough Excel to inhibit mould?
I don’t know what the latest CSM+B colour is because I don’t use it. Maybe someone will chime in who knows the product. I use Upgraded Trace Mix.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top