The Planted Tank Forum banner
1 - 9 of 9 Posts

·
Premium Member
Joined
·
116 Posts
Discussion Starter · #1 ·
I have never used substrate designed specifically for plants so I figured i would give it a try while setting up my new 36g. I bought a bag of Flora max, gave it a decent rinse and put it in the tank, then filled it. It's been about an hour with the filter running and its absolutely 1 huge dirt cloud. Is this expected? Did I not rinse enough? I am hoping it clears up overnight.
 

·
Registered
Joined
·
63 Posts
it does, but it clouds back up pretty easily when you disturb it.



but I'm happy with the way it looks, we'll both see if it grows plants well as I'm waiting for our local auction to get plants for the tank I put it in.
 

·
Premium Member
Joined
·
116 Posts
Discussion Starter · #3 ·
it does, but it clouds back up pretty easily when you disturb it.



but I'm happy with the way it looks, we'll both see if it grows plants well as I'm waiting for our local auction to get plants for the tank I put it in.
Hmm, I might try putting a layer of something more generic over top then if its gonna keep making the tank cloudy like this every time I vacuum it.
 

·
Registered
Joined
·
12 Posts
I had to wash this stuff for an hour before I felt ok putting it into the tank. I ran water over it in a 5 gal bucket and swirled it around intermittently, emptying and refilling the bucket.

Thank goodness for basement sinks!
 

·
Registered
Joined
·
63 Posts
it cleared up really nice in my case, but does kick up some dust when disturbed,,, the dust is really really heavy tho, and settles out in less than an hour or so...

So overall I'm happy, now to get planted and growing.....
:icon_lol:
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top