The Planted Tank Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
312 Posts
Discussion Starter · #1 ·
Well it finally happened. i have some sort of algae growing in my tank. i'm getting what i think is gsa on the glass which i can deal with but it is now starting on my micro swords and money wort =[ also on the micro sword are these green balls they are really green almost neon. i have 40 watts of light over the tank (10 gallon) 10 hour photo period. DIY CO2, i'm using kent freshwater ferts my nitrates are a little high at the moment (40 - 60) but i've been doing daily water changes to fix this. everything else is very low to 0. i can put up a pic when i get home from work but i just figured i'd post this now to see if anyone could help out =]
the tank is moderately planted so i don't think a lack of plants is a problem.
thanks!
 

·
Registered
Joined
·
3,254 Posts

·
Registered
Joined
·
312 Posts
Discussion Starter · #3 ·
yea i figured i'd get that response =] now with the dry ferts greg watson has what do i need? Is the PMDD Pre-Mix what i should get or do i need something else too? i've read up on this but its just confusing and my tank is only 10 gallons. most people talk about dosing larger tank.
 

·
Registered
Joined
·
1,394 Posts
BBA!!!!!!! RUNNNNNNNNN! yea, that's from a lack of co2 as the wonderful lynn said.
 

·
Registered
Joined
·
312 Posts
Discussion Starter · #6 ·
haha well i did i'm at work but it's still gonna be there when i get home =] well i refilled my diy co2 last night and did another water change. is there anything i can do to get rid of whats on the plants now or will it just go away with more co2? there is also some growing on the driftwood i have in the tank.
 
1 - 6 of 6 Posts
Top