The Planted Tank Forum banner

Eheim Pro II 2126 Cavitation Problem

1653 4
I have an Eheim Pro II 2126 that has been in service for about 6 months. The first four months it ran smooth and quiet. After a routine cleaning and reassembly, I get intermittent impeller cavitation and subsequent air bubbles through the output hose. I have tried a different pump head with a brand new head gasket that produces the same results. There is no external water leakage and the inlet and output are nowhere near each other to introduce any air into the system. Any ideas or suggestions?
1 - 5 of 5 Posts

·
Banned
Joined
·
5,279 Posts
I have a 2026 and it is dead silent. After a cleaning it generally takes a few days to expel all trapped air. If you give it a gentle shake a few times in the first 24 hours you can speed the process of riding itself of all the air trapped inside.

After that, if you are still experiencing bubbles from the spraybar, you have an air leak somewhere. You may have to remove the hoses from the quick disconnect and reseat them.
 

·
Registered
Joined
·
379 Posts
You may have a leak in the intake line. You won't notice leaking water because the leak will be sucking in air not expelling water. So I'd look it over and see if you can find a spot that looks like it might be letting air in.

If not, then like stated above, it may just take a while to get all the air out of the canister.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top