The Planted Tank Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
494 Posts
Discussion Starter · #1 ·
Hi
I have a problem with the above filter. I cant release the hoses out of the filter.
I close the valve ( all way to the right) and try to press the red release button and it won't allow me to press it .
I was wondering if anyone had the same problem ...
Thx
 

·
Registered
Joined
·
3,647 Posts
I can't help with the immediate problem, but I do have a 2076 and if you keep the o-rings on the safety adapter lubed it will prevent them from sticking in the future.

Good luck with getting it out.
 

·
Registered
Joined
·
494 Posts
Discussion Starter · #3 ·
I can't help with the immediate problem, but I do have a 2076 and if you keep the o-rings on the safety adapter lubed it will prevent them from sticking in the future.

Good luck with getting it out.
yeah I usually lube them after cleaning too. The way it is stuck is not dry o-rings tho. I believe there is some kind of interlock , between valve and the release; if the valve isn't closed, you cant release the hoses and I think that interlock is messed up in my filter or something is stuck in the valve and I am not closing it 100% .
 

·
Carpe Diem
Joined
·
7,562 Posts
I would try moving the flow lever control left and right couple of times. Also try to move the adapter gently up and down.
I have four 2075s... Pushing down on the adapter with my thumb while pushing in the red release button with another thumb got the release button unstuck the one time it was acting up on me.

HTH
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top