The Planted Tank Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter · #1 ·
Hi everyone,
I put in two bags of Eco Complete into the tank. The first one smelled pretty strong and foul but I never used Eco Complete before and figured it was normal. I opened the second bag and dumped it in as well. I smelled both bags and the first had a noticeably stronger smell. Now my tank looks like this: I've been running my aquaclear the past 2 hours or 3 hours, did 3 water changes. The water doesn't smell like anything but was the first bag a "bad batch"? Amazon is sending me another one but are both batches of eco complete useless now? I'm incredibly irked by this mishap and I wish I didn't dump the second bag in. So frustrated. You can't tell but the water has a yellow tinge to it.

 

·
Registered
Joined
·
1,302 Posts

Thats what mine looked like after about 3 hours worth of filtering. Mine smelled foul as well, but now about a month later, my plants are growing happy, and no problems with water clarity. I just dumped mine right in the tank. And lit a handful of candles LOL. I just did about 50% water changes for 2-3 days, and the tank is now fine.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #3 ·

Thats what mine looked like after about 3 hours worth of filtering. Mine smelled foul as well, but now about a month later, my plants are growing happy, and no problems with water clarity. I just dumped mine right in the tank. And lit a handful of candles LOL. I just did about 50% water changes for 2-3 days, and the tank is now fine.
I see, thank god everything is ok! I was so ticked off and upset. I guess it comes with setting up my first tank! Do you think I can add fish while the water is somewhat cloudy? My Corydoras are pouting in a 5 gallon bucket
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #6 ·
I don't want to do a water test since I used Prime. I think Prime skews the results.

The cloud settled down after about 6 hours I think. The water is a little cloudy but the cory cats seem to be doing ok for now. They've colored up and are happily swimming about. No rapid breathing.

I talked to Amazon and they decided to send me a replacement bag free of charge. But it's a little too late for that...
 

·
Registered
Joined
·
5,576 Posts
I don't want to do a water test since I used Prime. I think Prime skews the results.

The cloud settled down after about 6 hours I think. The water is a little cloudy but the cory cats seem to be doing ok for now. They've colored up and are happily swimming about. No rapid breathing.

I talked to Amazon and they decided to send me a replacement bag free of charge. But it's a little too late for that...
If your tank has not cycled, the cory's wil be NFL (not for long).
 

·
Registered
Joined
·
1,629 Posts
How did you fill your tank? I've never had this happen using eco either. I fill my new tanks with newspaper or plastic over the top of the substrate so I don't disturb it. I'm guessing you filled right over it?

As for smell, I've never had a foul smelling bag, hopefully it didn't have anything spoil in it before packing.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #9 ·
If your tank has not cycled, the cory's wil be NFL (not for long).
I cycled it by using media from an established tank. I'm a little bit confused why are you asking about the tank being cycled. This was a bare bottom tank and I decided to add substrate to it, not a new tank. Does the cloudiness only happen when the tank isn't fully cycled?

But I'm doing 20%-40% water changes everyday to help get rid of the dust from the Eco Complete as my cory cats keep disturbing the substrate.

How did you fill your tank? I've never had this happen using eco either. I fill my new tanks with newspaper or plastic over the top of the substrate so I don't disturb it. I'm guessing you filled right over it?

As for smell, I've never had a foul smelling bag, hopefully it didn't have anything spoil in it before packing.
I emptied out half the water and dumped in the Eco Complete. I was just worried because I read that the cloudy water settles pretty quickly and it wasn't supposed to have a yellow tinge. And the bag smelled pretty bad compared to the second one. I put the fish in a few hours later (like 8 when the cloud was pretty much gone)
 

·
Registered
Joined
·
43 Posts
I've had this happen to me with a bag of eco-complete... I didn't drain out all the water from the tank, and ended up with a cloudy mess. I would get the fluval pre-filter thing for $2 if you have a HOB filter; it does help. As for the smell, to me it kind of smelled like rainwater/wet dirt/sulfur-ish, but I've never encountered a bag with a yellowish tinge... perhaps it's part of their new "amazon blackwater forumula" or whatnot.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #11 ·
I've had this happen to me with a bag of eco-complete... I didn't drain out all the water from the tank, and ended up with a cloudy mess. I would get the fluval pre-filter thing for $2 if you have a HOB filter; it does help. As for the smell, to me it kind of smelled like rainwater/wet dirt/sulfur-ish, but I've never encountered a bag with a yellowish tinge... perhaps it's part of their new "amazon blackwater forumula" or whatnot.
Yeah I have the Fluval Prefilter and it's working overtime! I had to rinse that thing out 6+ times and rinse my filter media 6+ times haha

The cloudiness is starting to go away. I bought some water polishing pads to do the rest.
 

·
Registered
Joined
·
5,576 Posts
I cycled it by using media from an established tank. I'm a little bit confused why are you asking about the tank being cycled. This was a bare bottom tank and I decided to add substrate to it, not a new tank. Does the cloudiness only happen when the tank isn't fully cycled?

But I'm doing 20%-40% water changes everyday to help get rid of the dust from the Eco Complete as my cory cats keep disturbing the substrate.



I emptied out half the water and dumped in the Eco Complete. I was just worried because I read that the cloudy water settles pretty quickly and it wasn't supposed to have a yellow tinge. And the bag smelled pretty bad compared to the second one. I put the fish in a few hours later (like 8 when the cloud was pretty much gone)


Sorry,,Can only respond to what has been posted.
You indicated this was your first tank,no mention of seed material from established tank (friend's? Other family memeber?)
How long after seeding the tank with bacteria from?? were fish added?
Some folk's seed their tank's but wait week's before placing fish in the tank or feeding tank bit's of food to keep bacteria alive.(bacteria need's food)
Test result's for ammonia,nitrites,nitrates would help other's detrmine whether cloudinesss was bacteria bloom or cloudiness from product,or possibly both.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #14 ·
Sorry,,Can only respond to what has been posted.
You indicated this was your first tank,no mention of seed material from established tank (friend's? Other family memeber?)
How long after seeding the tank with bacteria from?? were fish added?
Some folk's seed their tank's but wait week's before placing fish in the tank or feeding tank bit's of food to keep bacteria alive.(bacteria need's food)
Test result's for ammonia,nitrites,nitrates would help other's detrmine whether cloudinesss was bacteria bloom or cloudiness from product,or possibly both.
Sorry I didn't mention all the necessary information :O
Yeah I added fish in after I let the tank run for a few hours. I think that was a big screw up... The biomax rings I got from another person was in their aquarium for maybe about two years?

Load up a lot of activated carbon in your filter for the first month, then switch that over to purigen. That will help extract a lot of the initial impurities.
Will do. Ordering it on Amazon now!
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top