The Planted Tank Forum banner

DSM now algae

682 Views 5 Replies 2 Participants Last post by  mageikman32
2
So i been doing a DSM on my tank for about 6 weeks now and my HC has been growing like crazy so on monday i decided to fill it. its now thursday and im getting algae like crazy in between the HC and also on the substrate. Anyone know what it could be from and how i can take care of it. I was thinking about just doing 20 to 30% water changed everyday for the next 3 to 4 days and see if that works.

Attachments

See less See more
1 - 6 of 6 Posts
2
Hey looks like a great carpet. I started via the DSM and had the same issue. Hydrogen Peroxide helps. I wouldn't worry bout it too much though it's good to have a little.

However I don't think that is HC see below this is my HC carpet....



Have you got CO2 hooked up?





Sent from my iPhone using Tapatalk
See less See more
Actually comparing the photos maybe it is. Just looks slightly different


Sent from my iPhone using Tapatalk
  • Like
Reactions: 1
here is a better picture..mine is just really bushy but trying to wait a week before i trim it so it can convert to sumerged

Attachments

See less See more
Looks fantastic this is def HC can tell now couldn't from the other photos. Looks great love the tank.


Sent from my iPhone using Tapatalk
  • Like
Reactions: 1
Looks fantastic this is def HC can tell now couldn't from the other photos. Looks great love the tank.


Sent from my iPhone using Tapatalk
Thanks just hope I can get ahold of this algae just tested the water I got high ammonia and nitrites so going to do some daily water changes

Sent from my SM-N910P using Tapatalk
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top