The Planted Tank Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter · #1 ·
I was cleaning my Eheim Ecco 2236 canister filer today. I took the impeller out and put it back in. When I can cleaning up after putting the filter back on the tank I noticed my workspace had a bunch of very small black balls on it. The seem to be some sort of plastic or ceramic.

Does anyone know if this where part of the impeller mechanism and I someone manage to dislodge them?

-- Jaime
 

·
Registered
Joined
·
588 Posts
As far as I know no aquarium pump has ball bearings exposed to water, especially in a context where they could loose their balls. Its all ceramic/plastic bushings.

The small black balls sound more like detrius or substrate to me.
 

·
Registered
Joined
·
143 Posts
there shouldn't anything else but the impeller assembly only. to give you a better idea how it looks like to confirm.... try googling the impeller and/or the manual for the specific filter to understand the assebly... hope that helps
 

·
Registered
Joined
·
5,576 Posts
Should be rubber grommet on both ends of the impeller shaft.(at least mine does)
The one on the end that goes into the well/hole that impeller is seated in ,usually stay's in the bottom of the impeller well.
I have lost it down the sink before, and used new one that came with spare shaft I had purchased .
 

·
Registered
Joined
·
127 Posts
Discussion Starter · #5 ·
Thanks for all the replies. It seems apparent the little black balls I was seeing where not associated with the filter or impeller for that matter. My workspace was actually the kitchen counter and who knows who else in the family was doing there. Its a misery I am yet to solve.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top