The Planted Tank Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
I've had the Ehiem 2217 for about 2-3 months. I've cleaned/replaced the carbon pad and filter floss. However, with the taps wide open it's not pushing out water like it did when I first got it. The flow isn't bad, IMO, because it's causing movement with my plants.

My question is, I have a feeling its the blue filter that may need to be rinsed in the tank water (I know not to use tap water). Would you recommend to rinse out all the media in the tank water too? or just empty out the top media and do the blue filter only? And how often should I clean everything?

I have to clean the tubes too cause they have build up in both the inlet and outlet so I just wanted to do everything in one shot cause it'll just be easier.
 

·
Registered
Joined
·
1,906 Posts
I rinse all the media in tank water or in my case untreated well water and have done so for years with no problems. As far as cleaning the hoses and hard piping, you will need a tube brush that fits the tubing properly and long lengths of hose needs to be creative using a wad of cloth tied in between 2 lengths of flexible wire that can be threaded through the hose.

Don't forget to remove the impeller and shaft (be careful not to drop it) and use a toothbrush to clean those items as well as the impeller cavity.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #3 ·
I rinse all the media in tank water or in my case untreated well water and have done so for years with no problems. As far as cleaning the hoses and hard piping, you will need a tube brush that fits the tubing properly and long lengths of hose needs to be creative using a wad of cloth tied in between 2 lengths of flexible wire that can be threaded through the hose.

Don't forget to remove the impeller and shaft (be careful not to drop it) and use a toothbrush to clean those items as well as the impeller cavity.
Thanks. i do have a brush on a felxible wire. one brush is thicker than the other. I've had it for a while for another filter I had but never used it cause it wasn't easy to use on plastic tubes that bent. And I cleaned the impeller and shaft the other day when I changed out the carbon pad and filter floss. That is what gave me an issue when I put it back because it wouldn't work. After a few tries, I finally got it to work.
 

·
Super Moderator
Joined
·
12,126 Posts
Another tip for cleaning long runs of tubing: tie one end of string to a small nut (that can fit through the tubing). Tie the other end of the string (make sure it is long enough to go through the entire length of tubing) to some cloth. Drop the nut through the tubing (the weight will make this easy). Once the nut is through, just pull the cloth through the tubing.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top