The Planted Tank Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 · (Edited)
So I got the controller today. With it I ordered (1) spare probe and cal solutions.

Heres the problem:

Opened both probes. Soaked and rinsed well in pure fresh made D.I Water for about an hour. Connected everything and checked pH with the 7.0 cal solution.

Can not get it adjusted with the cal 7.0 (even playing with the slope) less than 9.5.

So I check the other probe soaking for even longer now. It won't go less than 9.9.

So let them soak again for a while longer.

Same situation.

So defective meter? Any suggestions? I am going to let them soak all night and see what gives in the morning but hopefully you guys give me some good advice also them.
 

·
Registered
Joined
·
712 Posts
two bad reading from two different probes sounds like a controller problem. also, it's not a good idea to store your probes longterm in DI, RO or distilled water. -snafu

So I got the controller today. With it I ordered (1) spare probe and cal solutions.

Heres the problem:

Opened both probes. Soaked and rinsed well in pure fresh made D.I Water for about an hour. Connected everything and checked pH with the 7.0 cal solution.

Can not get it adjusted with the cal 7.0 (even playing with the slope) less than 9.5.

So I check the other probe soaking for even longer now. It won't go less than 9.9.

So let them soak again for a while longer.

Same situation.

So defective meter? Any suggestions? I am going to let them soak all night and see what gives in the morning but hopefully you guys give me some good advice also them.
 

·
Plant Lover
Joined
·
296 Posts
Call Milwaukee. They are very nice and responsive. They had a batch of bad probes for a bit, I think, from somewhere like Czechoslovakia, and will replace them for free if that is the problem.
 
1 - 3 of 3 Posts
Top