The Planted Tank Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I've had nerite snails for a few weeks now. I had four in my tank. A couple days ago, one died. The ammonia and nitrites were at 0, nitrates at 5. My other snails and my betta are all fine. I think it might have been old age, since he was always the biggest and slowest, but I'm not sure. Any other possibilities?
 

·
Administrator
Joined
·
17,883 Posts
I've had nerite snails for a few weeks now. I had four in my tank. A couple days ago, one died. The ammonia and nitrites were at 0, nitrates at 5. My other snails and my betta are all fine. I think it might have been old age, since he was always the biggest and slowest, but I'm not sure. Any other possibilities?
What are your other water parameters? pH? kh? gH? Temperature?

How long has the tank been cycled? How was it cycled? Have you used any medications or other treatments in the tank?

You mentioned Assassin Snails in another thread. Do you have Assassins in the tank?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
pH is 8.0, I'm not sure about gH and kH but my water is akaline and hard, temperature is 79f. The tank has been cycled for a few months. I've used food to add ammonia and bottled bacteria for two weeks to cycle. Fish out of cycle. I added ammonia after tank cycled before getting fish, and within 24 hours it was gone. I don't have assassins in this tank. I haven't used medications in this tank, as everyone seemed healthy.
 
1 - 3 of 3 Posts
Top