The Planted Tank Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Got up this morning to feed my tank, and I noticed that 4 of the white LEDs on the right side of my fixture were all out. When I get home today I'll see if there's anything I can fiddle with to revive them, but I'm not too pleased. I purchased it about 14 months ago, and it's been running on a timer for 12 hours a day. That works out to roughly 5100 hours of life, which isn't acceptable.

Hopefully it's something I can sort out myself without having to dump more money into another fixture. Between this issue and the Stealth heater recall, I'm not doing well with Marineland products. Now all I need is for my Penguin 350 filter to blow and I'll have the trifecta.

:icon_evil
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #3 ·
I just got off the phone with customer service, I'm going to have to ship the fixture to them for repair. I'm not sure how the plants in my tank will handle this, as they're not particularly needy plants, and the tank itself is in front of a window. I can open the curtain and let the sun take care of things for a few days, I suppose.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #9 ·
I'm in Spotswood, central NJ, but I think I'll make do for the time being. I have a friend whose father said he would loan me a light, he's always upgrading and fiddling around the the lights on his marine tank.

Thanks though!
 

·
Registered
Joined
·
2,940 Posts
I'm in Spotswood, central NJ, but I think I'll make do for the time being. I have a friend whose father said he would loan me a light, he's always upgrading and fiddling around the the lights on his marine tank.

Thanks though!
no problem buddy, lmk if u change ur mind, i'm not far. i'm in NE philly near franklin mills mall.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top