The Planted Tank Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hello all, I am pretty new to pressured co2, and have recently set one up.
But i am having a problem that when I turned my co2 on the bubble would go say 2 bubbles/sec, then slowly over a while, it would go back to 1 bubble/sec, eventually end up to none. Then I would adjust it back to 2 bubbles but the same thing would repeat. Can anyone help me with this please? Thanks.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·

·
Banned
Joined
·
5,009 Posts
Try increasing the working pressure and then set your bubble counter with the needle valve. You may have to "fiddle" with it for a while to get it fairly stable. Should the needle valve be of low quality and you can't get a consistent enough bubble count, you should replace it with a Fabco, Ideal or Swagelok needle or metering valve.
 

·
Registered
Joined
·
4,701 Posts
Hello all, I am pretty new to pressured co2, and have recently set one up.
But i am having a problem that when I turned my co2 on the bubble would go say 2 bubbles/sec, then slowly over a while, it would go back to 1 bubble/sec, eventually end up to none. Then I would adjust it back to 2 bubbles but the same thing would repeat. Can anyone help me with this please? Thanks.
This is a classic sign of a pressure leak. You should check your tubing connections for leaks before you make any adjustment to your system. Your working pressure is likely fine. You can use soapy water to test for leaks on all connections of your system.
Once you give the system a good soapy bath, let it sit for a few minutes while running and check for any extra foamy connections.


Regards,
Orlando
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top