The Planted Tank Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 75gal, medium planted tank. The substrate is fine gravel mixed with Seachem Flourite. I do inject DIY CO2. Lights above the tank are staggered with two 54W (10K and 12K) being on for 8 hours and two 6700K being on for 4 hours. Plants include Jungle Vals, Amazon Sword, Apongeton (x2), one Anubias Nana and a water Lilly (pleco loves that plant so it has just lost a lot of its leaves due to being eaten). I do change about 15 gal once a week. I do use about 5cc of Seachem Flourish with water changes. Filter is a canister Aquatop CF 500. The tank has been set up for about three months.

My main problem is slightly cloudy water, it is just a light haze that rarely goes away. I have tried different filter media, frequent water changes, vacuuming the gravel, the cloudiness keeps on persisting. The gravel was rinsed well before tank was set up. All the chemical measurements are within normal limits. The tank is actually more hazy than cloudy

Here are the fish that are in the tank
1 koi angel
3 keyhole cichlids
10 cardinals
6 cherry barbs
4 celebese rainbows
5 sterbai cories
1 BN pleco (around 4in)
1 black brevis

I am wondering if the bioload is too high on the tank or if it is the substrate that is being stirred up by the cories.
 

·
Registered
Joined
·
1,528 Posts
Well, let it be. Add more fast growing plants or reduce the stock. I have Cory cats in a couple tanks, no cloudy water unless I disturb something. A burrowing banjo in a dirted tank with no issues...

What media do you use in the aquatop? My first came with 3 white pads, my second came with a coarse sponge and 3 pads.. the coarse sponge needs to be cleaned only twice a year for me, otherwise bimonthly poly-fil changeouts on the other canister.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top