The Planted Tank Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
545 Posts
Discussion Starter #1
I just separated the motor portion from the eheim, the seal is leaking. Have the new seal. Does anyone know how to change/install the seal. Could really use some help. It is on the kitchen counter LOL

Did I mention I need some help!!!!!!!
 

·
Registered
Joined
·
545 Posts
Discussion Starter #3
deeda So sorry on my part it's the canister seal the one that goes around the edge sealing the motor unit from the media container. This seal is quite large. Not the oring. Thank You!!!!!
 

·
Registered
Joined
·
1,711 Posts
Yes, I used the Eheim lube or a potable water safe silicone grease to lube up the seal before reassembly. Sorry I misunderstood your original question. I used a safety pin to pry my old canister lid seal out.
 

·
Registered
Joined
·
1,711 Posts
Just use a very thin coating, enough to make the seal slippery. No gobs or chunks.
 

·
Registered
Joined
·
6 Posts
did replacing the ring around the top unit solve the problem? if so, where did you buy the replacement ring? thank you for this posting that i found thru google which also led me to The Planted Tank.
 

·
Registered
Joined
·
474 Posts
Bought seals, also quick disconnects recently from Big al's they were the cheapest although shipping kills you,got the primer 'O' ring from atomic rice.
had 2 pumps leaking one was primer & media container to pump head seal & other was cracked quick disconnect....well worth repairing !! hopefully another 5yrs of trouble free service :icon_mrgr
 
1 - 10 of 10 Posts
Top