The Planted Tank Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
171 Posts
Discussion Starter · #1 ·
I bought this anubias yesterday from a Petco plant tank. It looks to have blue-green algae on the leaves. I have bleached it, doused it in Hydrogen peroxide, but doesn't seem to make a difference. Nothing scratches off the leaves either. Can I save it? Or should I just trash it? I could also clip the affected leaves off, as there are a few that aren't affected. But I don't want anything to spread to the rest of my tank either. You can really only see it under water in the LED light.

Thanks for any help!
 

Attachments

· Registered
Joined
·
171 Posts
Discussion Starter · #4 ·
I'll try a stronger bleach dip. I've tried scratching it off with my fingernail, but it's still there. It may be a change in pigment on the leaves, I'm not sure. My biggest concern is if it may be Cyanobacteria due to the blue-green color. I plan to save it for my 40B, so I planned to just wedge it in the driftwood for now.
 

· Registered
Joined
·
171 Posts
Discussion Starter · #6 ·
Cyanobacteria in freshwater grows like a green-blue slime . If you just rub your finger over it, it will go detach. So from your description it should not be cyanobacteria.



It looks to me like either dense green spot algae, green round spots that are very hard to remove (in this case high P seems to reduce them) or green-yellow leaf zones from low nitrogen.


Thank you!


Sent from my iPhone using Tapatalk
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top