The Planted Tank Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter · #1 ·
Right now, I'm using an AC 110 with an AC quick filter (their power head attachment) as a pre-filter
This mod has been working great with my AC70, but the 110 it's clogging up much faster, usually within 2 weeks and I have to replace the filter sleeve

Is there a better way to have a prefilter (I have some shrimp and fry) that won't need to be replaced so fast?

I read on a post that fluval makes a pre fillter
And hydra makes one
But how fast do those clog up
Right now my AC is at a trickle
 

·
Are these real?
Joined
·
15,750 Posts
The AC prefilter cartridge is just supposed to be used for a temporary "polishing" say after you pulled out some plants.

As a more permanent solution, you can stick one of the regular AC sponges onto the inlet. They are coarse enough to not clog up that fast, but still need to be cleaned fairly often, two weeks sounds very normal. With a pre-filter you move some or most of the mechanical filtration that normally takes place in good-sized media chambers to a small spot that just clogs up fast.
 

·
Registered
Joined
·
118 Posts
Discussion Starter · #4 ·
I didn't know that about the AC prefilters
I thought they were suppose to be used with the power heads as a secondary filter not for temporary use.
I know a prefilter takes the place of the sponge in the AC...maybe that's why I never had to replace it :)
But with fry and shrimp you need something
I guess I'll give a sponge a chance
 

·
Registered
Joined
·
5,116 Posts
Anything I seem to use gets clogged up quick. Its a toss up between a prefilter and cleaning it all the time or nothing and having a shrimp baby sucked up into it. lol. My roomie works at a window factory and is bringing me home some plastic mesh animal grade screen, so I'm going to try that instead just to keep the shrimp out.
 

·
Registered
Joined
·
352 Posts
I use the fluval prefilter on my edge and I have to squeeze it out due to clogging umm.. I just had to do it for the second time since I set it up in march. Maybe my tank is cleaner than other people's but I don't know, its QUITE heavily stocked with fish and I do a decent amount of meddling around wtih my tanks and stir up substrate quite often so maybe I just get lucky :p Once every couple months I notice the flow decreasing and just squish it out and haven't ever had to do more work than that
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top