The Planted Tank Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Tank # 1: Has white hair like algae that has now hooked itself to the top layer of the substrate. Please advice what to do. Or is it time to ditch the tank ?


Tank # 2: Keeps getting green hair like algae on the plants ...... I have to remove it every alternate day. Any cures for that. Also I have white spots of the glass in the back of the tank. They are not going away by my scrapper ....


Is there any good ADA product to remove White and Green Hair like Algae
 

·
Registered
Joined
·
4,907 Posts
The best product out there is........routine care and maintenance. There are chemicals that kill algae however. If ur tank is not balanced between light fertilizers and c02 if u have it, algae will always come back..until u fix the root problem it will be an ongoing battle until u do decide to ditch the tank. Tank #1 sounds like detritus worms to me. Do a vac and lower ur feeding a little
 

·
Registered
Joined
·
5,994 Posts
I completely agree with HD Blazingwolf on balance. Re-evaluate your photo period/intesity and Fert. protocol.

I would suggest you:

A) Physically remover as much as you can.
B) Do a large water change 30%
C) Read the threads on this site about HO2O (Hydrogen Peroxide)
BEFORE you start any chemical warfare campains
D) Consider natural Algae solutions, shrimp, Fish, snails.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top